Linux kernel 版本不包含GIT 字串


如你載入模組發現下列錯誤訊息


[XXX /]# insmod /lib/modules/xx-gpio.ko
xx_gpio: version magic '2.6.29.09.00 preempt mod_unload ARMv5 ' should be '2.6.2
9.09.00-g1c6039c preempt mod_unload ARMv5 '
insmod: can't insert '/lib/modules/xx-gpio.ko': invalid module format


則是因為GIT版本也被加進去
所以改一下吧


General setup  ---> 


   [*] Automatically append version information to the version string


把這個拿掉 載入模組時就不會因為次版本不同...而不能執行了


 

立你斯 發表在 痞客邦 留言(1) 人氣()