</br> 

Ubuntu缺省情況下,並沒有提供C/C++的編譯環境,因此還需要手動安裝。


如果單獨安裝gcc以及g++比較麻煩,幸運的是,為了能夠編譯Ubuntu的內核,Ubuntu提供了一個build-essential軟件包。


查看該軟件包的依賴關係,可以看到以下內容:


  $ apt-cache depends build-essential


  build-essential


  |依賴: libc6-dev


 依賴: <libc-dev>


  libc6-dev


 依賴: gcc


 依賴: g++


 依賴: make


 依賴: dpkg-dev


也就是說,安裝了該軟件包,編譯c/c++所需要的軟件包也都會被安裝。因此如果想在Ubuntu中編譯c/c++程序,只需要安裝該軟件包就可以了。


 安裝方法如下:


$sudo apt-get install build-essential


有編譯需要的 先裝完在說吧 不然一堆編譯錯誤 怎死都不知道

    全站熱搜

    立你斯 發表在 痞客邦 留言(0) 人氣()