downloaded latest build of blueman from:
git clone https://github.com/blueman-project/blueman

cd blueman

sh autogen.sh

出現錯誤 
懶的看的可以直接安裝需要的庫
sudo apt-get install autotools-dev
sudo apt-get install automake
sudo apt-get install libtool m4 automake
apt-get install autoconf autogen intltool libtool automake autotools-dev libopts25 libopts25-dev

apt-get install python3.5-dev libpython3.5-dev
apt-get install python-gobject-dev
apt-get install cython


#  ./autogen.sh
I am going to run ./configure with no arguments - if you wish
to pass any to it, please specify them on the ./autogen.sh command line.
./autogen.sh: 23: ./autogen.sh: aclocal: not found

 

apt-get install autotools-dev
apt-get install automake

autogen.sh: 25: autogen.sh: libtoolize: not found
 

sudo apt-get install libtool m4 automake

autogen.sh: 26: autogen.sh: intltoolize: not found

 apt-get install autoconf autogen intltool libtool automake autotools-dev libopts25 libopts25-dev


configure: error: Package requirements (python-3.5) were not met
apt-get install python3.5-dev libpython3.5-dev

No package 'pygobject-3.0' found

apt-get install python-gobject-dev

configure: error: "Fatal: cython not found

apt-get install cython

 



run
./configure

then
sudo make

then
sudo make install

sudo hciconfig hci0 up

blueman-manager

立你斯 發表在 痞客邦 留言(0) 人氣()